
Need help? Tel: 1300 724 667  Email: support@surefire.com.au    
 

Copyright © 2010. No part may be reproduced by any means without the permission of SUREfire systems. 

PRO- 2i Page|   1 of 4 

Category Product 

Course Pricing 

Version 1.0 

Client Generic 

Software 2.15.8 

 

 

Create or Edit Bulk Promotions or Deals 

Use the Bulk Promo Maintenance utility to edit several 

products on one screen: 

 Create a deal to add an additional deal component. 

 Add non-catalogue promotions. 

 Fix a promotion/deal saved with incorrect parameters. 
 

Procedure to Add or Modify a Promotion or Deal 
 

1.  From the HOS/BOS Windows desktop: 
a. double-click the SUREfire HOS (BOS) folder. 

b. Double-click BulkPromoMaint.exe. 

c. Enter your HOS/BOS User name & Password, 
and then click OK. 

*The application opens.* 

    
 
 

 

2.  To create/edit a 
promotion/deal: 

then: 

by typing the  
product/s 

go to step 3. 

off an existing 
promotion or 
deal record 

 (you can still 
add/remove 
products after 
they load into 
the grid) 

click the Home tab. 

Enter the required Year, 
Week or Date to retrieve. 

*See Hints and Tips.* 

Select to retrieve either 
Promotions or Deals. 

Optionally enter/select other 
filters to narrow the results. 

Click . 

Go to step 5. 

off an import 
file (you can still 
add/remove 
products after 
they load into 
the grid) 

click the File tab. 

Click . 

Navigate to and open the file 
(either by searching or 
typing the filename). 

*A preview is displayed.* 

Select the file Type. 

Click . 

Click OK. 

*The file is displayed in the 
grid; if there were errors, 

click OK, , correct 
the file, and import it again.* 

Go to step 5. 

*The bottom left of the screen indicates how many 
records were retrieved.* 

 
 
 
 

 
 
 

 
 

 
 

 
 

 

   
 

Hints and Tips 
 
 Also refer to the PRO-2k BPM 

Enquiry/Deletion Fact Sheet and 
the PRO-2j BPM Create Bulk 
Leading Promotions Fact Sheet. 

 
 Records created in the utility:  

 are saved against a products 
default supplier. 

 start at 00.00.01 and finish at 
11.59.59 

 display on the Stock screen 
(deal values will include GST). 

 
 Use Max Days to filter out any 

promotions/deals that run 
longer than the number entered. 
 

 When you Load a selected Date, 
the system returns: 

 all existing promotions (for the 
Loyalty Pricing level selected) 
that are active during the 
selected week; Deal Promo 
Calc must have been run to see 
imported data. 

 the ‘best’ deal with the same 
scope (or broadest scope if no 
match) that falls within the 
promotion; e.g. if you load by 
Promotions,  a deal won’t 
display if it ends before the 
promotion ends  (if you need 
to review these deals, load by 
Deal instead). 

 
 You can Import a spreadsheet 

created by yourself or a supplier. 

 contact SUREfire Support for a 
template the utility recognises. 

 The data must exclude GST. 

 A ‘deal reflect’ promotion retail 
may be auto- generated in the 
grid if the import data includes 
promotion dates, rounded to 
nearest 5 or 9 cents and based 
off the normal retail in the 
selected Zone for GP calc. 
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3.  Complete the following steps if you want to 
add products to the grid manually: 

To: then: 

add a 
specific 
product 

at the top of the grid, click the 
Stock Code field in the ‘Click 
here to add a new product’ row. 

Type the stock code. 

Press Enter. 

*The product is added.* 

add a 
specific sub 
range of 
products 

(you can only 
work on 
Affect single 
OR sub range 
in the grid at 
one time) 

at the top of the grid click the 
Sub Range field in the ‘Click 
here to add a new product’ row. 

Type the sub range code. 

Press Enter. 

*A sample active product in the 
sub range is displayed.* 

*At step 6 you’ll select Affect 
option Sub Range EANS.* 

search for a 
product or 
group of 
products to 
add to the 
grid 

click  from the 
quick menu bar or the File tab. 

Type criteria in the applicable 
field/s; the search starts 
automatically. 

Select required product/s and 

click  OR click . 

*Hold the Shift or Ctrl key down 
to select multiple products.* 

Click Close when ready to 
return to the grid. 

*The products are listed in the 
grid.* 

Go to Step 5. 

 
 
 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 

 
 

4.  Select the Insert check box if you want edits 
made to any existing records to save as new 
inserts from now on (rather than override). 
*See Hints and Tips.* 

*You can switch between modes for each row.* 

*Add the New Deal and New Promo columns to 
the grid to see how your data will save.* 

 

   

Hints and Tips 
 
 Function buttons: 

 Cancels the previous 
selection/data entry 
(one per click). 

 
The grid goes into 
search mode; click 
the cursor in a 
column (e.g. Stock 
Code), as you type, 
the cursor jumps to 
the match. 

 
Unselects all the 
Lock check boxes on 
the Locks tab. 

 
Clears the grid. 

 

File tab; save data to 
open in Excel. 

 
File tab; create a 
leading promotion. 

 
Search for a product 
to add to the grid. 

 
 

Switch to ‘save as’ 
mode; edits to 
existing records will 
save a new record 
rather than updating 
the existing one. You 
can also set the 
mode from the File 
tab. 
If you only change 
retail, it always saves 
in update mode. If 
no promo/deal 
exists, these save as 
new inserts.  

 
If the cursor is on the 
last row visible & you 
press Enter or down 
arrow, the screen will 

scroll down a full 
page & position the 
cursor at the top of 
the page. 

 
File tab; import a file. 
SUREfire must first 
map the spreadsheet 
template/s you’ll use 
to the utility.  

 
File tab; removes 
highlighted rows 
from the grid.  

 
File tab; deletes 
selected rows; you 
confirm to delete the 
promo and/or deal. 
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5.  If a HOS user, select the Scope the pricing 
applies to (via the Home tab). 

*Initial scope defaults to All Stores. If a list is 
displayed, you can select multiple location/s.* 

*Scope isn’t used for a BOS user.*  

6.  Select the required Affect: 

Select: to apply the pricing: 

Current 
Items EANS 

only to the products in the 
grid. 

Sub Range 
EANS 

to every active product that 
belongs to the sub range/s 
listed in the grid, which has the 
same units per pack. 

*The products for a selected 
sub range are listed in the Items 
to be applied box.* 

 

 
 

 
 

 

 

7.  If a HOS user, select the applicable Zones 
for GP Calc. selection. 

*This also controls which supplier/stock code 
displays if there are different default suppliers 
across zones (important if a deal only applies to 
that supplier).* 

*This field isn’t applicable for a HOS-driven single 
zone business, and isn’t used for a BOS user.* 

 

8.  If applicable, complete the following steps to 
create or edit a deal (depending on if the 
Insert check box was selected at step 4): 

a. Select the Selected check box/es against the 
products you want to bulk edit. 

b. On the Locks tab, in the Off Invoice, WW, or 
Scan lock field/s, type the case discount. 

c. Select the Deal Start & End Date lock values. 

d. Type the Deal Ind. lock value. 

e.  Select the corresponding Lock check box/es. 

*The locked values are populated against the 
selected products (row/s) in the grid.* 

*Alternatively, type values directly in each row; the 
Lock check box must be unselected (and you don’t 
use the Select check box for this data entry).* 

* Locked check boxes are cleared when you change 
tabs; this avoids accidently applying a previous lock 
value to a new selection.* 

 
 

 
 
 
 

 

 

 

   
  

Hints and Tips 
 
 You can only select one Scope, 

Affect and Zone for all the 
products listed in the grid.  

 Scope: the stores the pricing 
applies to. 

 Affect: the products that will 
receive the new pricing. 
Important: If editing records 
originally created at item level, 
if you change the affect to 
sub-range it creates a new 
promotion/deal; so if you 
make a promotion dearer, the 
cheaper one will still apply. 

 Zones for GP Calc: which zone 
is used to populate the regular 
retail, cost and GP columns. 

 
 Greyed fields are read-only. 

Data entry is also disabled when 
you Lock a field or use Search. 

 
 Use the Lock & Select check 

boxes to bulk edit rows; this 
saves time when several 
products have the same values. 

 You can select a Lock check 
box before or after you select 
the Select check box. 

 
 Sometimes a supplier gives you 

an additional deal on top of a 
hosted ‘off invoice’ deal; you 
create this in ‘insert’ mode, off 
the original deal. 

 If the product belongs to a 
subrange, then the deal will 
apply against all the products 
displayed in the grid that 
belong to the same sub-range. 

 Use Deal Hold if you don’t 
want a deal to be exported to 
stores yet (HOS users only). 

 
 Types of deals: 

 Off Invoice: The case discount 
that’s reflected on the invoice. 

 WW: Warehouse Withdrawal 
(‘buy’ rebate). A case discount 
for purchases from the 
warehouse; follow business 
process to claim it. 

 Scan: (‘sell’ rebate).The dollar 
discount for every case sold; 
follow store process to claim. 

 Note: WW and Scan rebates 
will display as a deal in HOS 
Pricing; use MicroStrategy 
reporting to identify the 
rebate portion owing. 
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9.  If applicable, complete the following steps to 
create or edit promotions (depending on if 
the Insert check box was selected at step 4). 

a. Select the Selected column check box/es for 
the products to edit. 

b. On the Home tab, select the Loyalty Pricing 
level to apply against all items listed. 

c. Click the Locks tab. 

d. In the applicable Promo lock field/s above 
the grid, type or select the parameter/s to 
lock. 

e. Select the corresponding Lock check box/es.  

*The locked values are populated against the 
selected products (row/s) in the grid.* 

*Alternatively, type values directly in each row; the 
Lock check box must be unselected (and you don’t 
use the Select check box for this data entry).* 

*Leave the Promo Ret. field blank if you want to 
apply a deal reflect price when you save.* 

*You can’t save a promotion with a [0] new price.* 

* Locked check boxes are cleared when you change 
tabs; this avoids accidently applying a previous lock 
value to a new selection.* 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

10.  If required, complete the following steps to 
apply rounding to the promotions: 

a. Click the Home tab. 

b. Click the Select check box against the 
applicable rows to apply the rule against. 

c. Select the rounding rule to use. 

d. Click Apply. 

*The Promo Retail is updated.* 

 
 
 

 

11. \ Click . 

*The grid is cleared if all rows saved successfully.* 

*If an error displays, there’s an error with at least 
the top row; review the Invalid Reason column.* 

 

12.  To: then: 

manage another 
promotion or deal 

click . 

Return to step 2. 

finish click . 
 

 
 
 
 

 

13.  BOS users: print any promotion tickets. 

*Refer to the PRO-5i Print Promotional Labels by 
Indicator Fact Sheet.*  

   
 

Hints and Tips 
 
 Promotions: 

 If your business runs loyalty 
promotions, the selected 
Loyalty Pricing filters promo’s 
on load, and sets the 
customer loyalty price for new 
or existing promotions. 

 If the product belongs to a 
subrange, then the promotion 
retail automatically applies 
against all the products added 
to the grid that belong to the 
same sub-range and have the 
same UPP; if you change the 
price of one it’ll update 
against all.  This logic applies 
regardless of the Affect 
option selected at step 6. 

 A deal reflect price uses the 
regular GP and the difference 
between the Reg. Cost and 
Deal Cost to maintain the GP. 

 Use Promo Hold if you don’t 
want a promo to be exported 
to stores yet (HOS only). 

 If creating overstock 
promotions, add the deal 
associated with the original 
promotion; otherwise it will 
sell and report at wrong cost. 

 
 You can add as many rounding 

rules as you want.  

 

To add a rounding rule: 

1. Click . 
2. If you need a new group, 

click New Rounding Group 
& type a group name. 

3. Click New Rounding Rule 
and type a Name. 

4. Always select Department: 
Non Department Rule. 

5. If applicable, set a from/to 
for the rule (to: is inclusive; 
e.g. 49.99, if you only want 
the rule to apply when the 
price is between x and y). 

6. Tick ‘in rounding group’, 
to add this rule to the 
group selected in step 2. 

7. Type the rounding 
amounts in the rounding 
column, 1 through to 99. 

8. The rule is auto- saved. 
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