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Category BOS General 

Course Security 

Version 1.1 

Client Generic 

Software 2.12.100 

 

Electronic Audit Utility 

The Electronic Audit Utility is used to view and print specific 

transactions performed at POS. 
 

Procedure to Retrieve Transactions on a Stand-Alone PC 
 

1.  Copy and paste the required daily file/s from 
the BOS computer to a USB device. 

*The files are located in D:\Program Files\SUREfire 
systems\SUREfire BOS\Uploads; right click the file 
name to display the Copy/Paste functions.* 

 

2.  Double-click the ElectronicAudit.exe file. 

*You may access the utility from the Windows 
desktop, Start menu option, or Windows Explorer.* 

 

3.  From the File menu, select Import File. 
 

4.  Select the folder on your USB drive that 
contains the saved file/s. 

 

5.  Click the daily file that you want to review. 
*Date format in the file name is  year/month/day.* 

6.  Click .  

7.  Click . 

*You can open multiple files and then click Apply.* 

*The transaction/s is displayed on the screen.* 
 

 

8.  To: Then: 

change the view refer to Procedure to Change the View on page 3. 

apply a filter refer to Procedure to Filter Daily Records Retrieved on 
page 4. 

apply a search refer to: 

Procedure to Search Transactions on page 5. 

Procedure to Perform an Advanced Search on page 5. 

apply a sort refer to Procedure to Sort the Daily Records on page 3. 

open a different 
file 

return to step 3. 

print the view Highlight the transaction text to print. 

From the File menu, select Print. 

Click OK. 

*The transaction/s are printed from the default printer.* 

clear the 
retention period 
data 

from the File menu, select Empty Daily File Table, and 

then click . 

*This clears all data previously retrieved; you must 
import the daily files to rebuild the retention period.* 

finish click the [x] located at the top right-hand side of the 
application. 

 

     

Hints and Tips 
 
 Older files are achieved; 

unzipped the file to use it. 
 

 You can search for a specific or 
range of transactions: 

 on a specific date/time 

 by a specific operator ID 

 at a specific register 

 for a specific value or range 

 that included a specific 
product 

 suspended and/or resumed 

 that included a void, discount, 
authorisation, or gift card. 

 
 You can only access transaction 

information that was created in 
SUREfire 2.12.00 or later. 

 
 I.T Support Notes: 

 For a standalone installation, 
the file ‘sfsqlite3odbc.dll’ 
needs to be found in the same 
location as the 
electronicaudit.exe file.  
User has access to all tabs and 
import. 

 For a BOS installation, set the 
System Param 
ElectronicAuditUploadMode: 
1: shows all tabs & 
unrestricted file 
browsing/import. 
2: shows all tabs, only lists 
daily files for import. 
3: shows only Filter and 
Search tabs, no import option. 

 
 Function Buttons: 

 Applies the 
selection. 

 Clears all options 
selected in the 
open tab. 

 Clears all options 
selected in all tabs 
(File -> Refresh 
Tabs does the 
same action). 
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Procedure to Retrieve Transactions on a BOS Computer 
 

1.  Open the Electronic Audit utility. 
*You may access the utility from the Windows 
desktop, Start menu option, Windows Explorer, or 
the BOS Tools menu.* 

*If you open the utility outside the BOS, you’re 
prompted to enter a User Name and Password; 
this is the same as your BOS logon.* 

 

2.  To: Then: 

retrieve a list of 
transactions in 
the retention 
period displayed 

click . 

Go to step 3. 

import daily file/s 
(if access mode 
permits) 

from the File menu, select 
Import File. 

Click the required file. 

*Older files are in the 
Achieve folder; go to the 
file path in Explorer, unzip 
the required file to a temp 
location, then import the 
file saved to this location. 

Click . 

Click . 

Go to step 3. 
 

 
 

 
 

 

 
 

 
 

3.  To: Then: 

change the view refer to Procedure to Change the View on page 3. 

apply a filter refer to Procedure to Filter Daily Records Retrieved on 
page 4. 

apply a search refer to: 

Procedure to Search Transactions on page 5. 

Procedure to Perform an Advanced Search on page 5. 

apply a sort refer to Procedure to Sort the Daily Records on page 
3. 

open a different 
file 

return to step 2. 

print the view Highlight the transaction text to print. 

From the File menu, select Print. 

Click OK. 

*The transaction/s are printed from the default 
printer.* 

clear the 
retention period 
data (if access 
mode permits) 

from the File menu, select Empty Daily File Table, and 

then click . 

*This clears all data previously retrieved; you must 
import the daily files to rebuild the retention period.* 

finish click the [x] located at the top right-hand side of the 
application. 

 

   
 
  

Hints and Tips 
 
 The retention period reflects 

the daily data that is retrieved 
when you click Apply. 

 
 

 If the retention period is the 
current day, you can click Apply 
at any time to update the data 
with any transactions 
performed since the retention 
time stamp. 
 

 Contact SUREfire Support if you 
need import permissions.  
 

 If the retention period grows to 
an excessive number of days, 
you can select File -> Empty 
Daily File Table to empty the 
table (restricted access). 
You must import the 
transaction data to rebuild the 
retention period. 

 
 

 Function Buttons: 

 Applies the 
selection. 

 Clears all options 
selected in the 
open tab. 

 Clears all options 
selected in all tabs 
(File -> Refresh 
Tabs does the 
same action). 

 
 File menu advanced access 

options: (restricted access) 

 Use only Daily File 
Information: usually keep this 
unselected, so that 
information retrieved from 
other tables is displayed. 

 Select Daily File Table: to 
create a new table with 
specific data. You create and 
retrieve a table by entering a 
table name (without spaces), 
then import files to include in 
the table. 
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Procedure to Change the View 
 

1.  From the View menu, select the required 
view.  

2.  
 

Select view: Or press: To display: 

Transaction 
Journal 

[Ctrl] [J] all the transactions in a receipt-like format. 

Transaction 
List 

[Ctrl] [L] all the transactions as they’re displayed in the 
daily file. 

Transaction 
Detail 

[Ctrl] [D] detailed information about a transaction; you 
must first select a Trans Pay Type on the Filter 
tab. 

Transaction 
Summary 

[Ctrl] [S] a summary of the transaction; you must first 
select a Trans Pay Type on the Filter tab. 

Transaction 
Totals 

[Ctrl] [T] the quantity & total value for each total, 
payment type, and miscellaneous item. 

Transaction 
Analysis 

[Ctrl] [A] the number of anomalies that occurred, and 
when and where the anomaly occurred. 

   

 
Procedure to Sort the Daily Records Displayed 
 

1.  Click the Sort tab. 
 

2.  Double-click a field to move it to/from the 
Sort Fields list and Available Fields list. 
*The Sort Fields list contains the fields that you’re 
currently sorting the transactions by.* 

 

3.  To prioritise the sort order, click the field 
and then the Up or Down arrow. 
*Transactions are sorted by the first field in the 
Sort Fields list, followed by subsequent fields.* 

 

4.  Click . 
*The transactions are sorted in the selected order 
in the view.* 

 

   

 

  

Hints and Tips 
 
 The Sort tab is used to reorder 

the transactions listed in the 
view. 
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Procedure to Filter Daily Records Retrieved 
 

1.  Click the Filter tab (or Range tab if 
displayed)  

2.  Select filter: To filter the results for: 

Store Number transactions processed at a 
specific store. 

Till Number transactions processed on a 
specific till.  

Operator transactions processed by a 
specific operator. 

Date transactions processed on a 
specific date. 

Transaction 
Type 

a specific transaction type, 
e.g. Item Void, Item Return. 

Trans ID a specific transaction ID. 

Trans Pay 
Type 

transactions with a specific 
payment type. 

E.g. Cash, Cheque, EFTPOS.   

Reason Type transactions that have a 
specific reason type. 

E.g. Price Change. 

Trans Start 
Code 

a transaction type of 47; e.g. 
03: suspended transactions. 

Event Type 
Code 

an event type of 82 (generic 
event log); e.g. 01: EFTPOS 
Logon Failure. 

Sales Total ($) a specific total sales amount.  

Training transactions that were 
created in training mode, 
that were not created in 
training mode, or both. 

 

 

3.  Use the drop-down box to limit the search 
results. 

 = equal to 

 < less than 

 <= less than and equal to 

 greater than 

 >= greater than and equal to 

 <> does not equal. 

 

4.  If you’re using the Range tab, you can 
specify a range using the Add and Or 
limiters. 

 
 

 

5.  Click . 
* Only the transactions that match your specific 
criteria are still displayed in the view.* 

 

   

 

Hints and Tips 
 
 If you want to clear the 

previous filter and start over, 

press Clear Tab then  to 
re-display all the records.  
 

 Users with access to the Range 
tab can perform the same 
filtering, but have extra search 
limiters. 
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Procedure to Search Transactions Displayed 
 

1.  Click the Search tab.  

2.  Select: To: 

Direction select the search direction. 

Start From select where you want the 
utility to start searching from. 

Search Type select a search type. 

Amount enter a specific amount or 
amount range. 

Qty enter a specific quantity. 

Reason Code enter a specific reason code. 

Stock Item enter a specific description of 
an item; e.g. coke. 

Text Code enter any text to search on 
(such as an EAN, AR Name). 

 

 

3.  Click .  

4.  If the search 
results are: 

Then: 

highlighted  click  to see the next data. 

displayed in 
a summary 
results 

double-click the transaction to 
display it in Transaction Journal 
view. 

 

 
 
 

 

   

 

Procedure to Perform an Advanced Search 
 

1.  From the View menu, select Transaction List.  

2.  Click the Adv Search tab. 
 

3.  To search: then: 

using 
common 
criteria 

double-click the required 
Common criteria. 

Enter a value in the Advanced 
Search screen. 

Click OK. 

Click  to highlight the 
next data found. 

using 
specific 
criteria 

from the Transaction Specific 
list, select the scenario. Double-
click the required criteria. 

Enter a value in the Advanced 
Search screen. 

Click OK. 

Click  to highlight the 
next data found. 

 

 

 
 

 
 

 

   

 

Hints and Tips 
 
 If you want to clear the 

previous search results and 
start over, press Clear Tab then 
Find to re-display all the 
records. 

 
 Basic Search is used to search 

for specific types of 
transactions: 

 on a specific date/time 

 by a specific operator ID 

 at a specific register 

 for a specific value or range 
(e.g. refunds $10-$20) 

 that included a specific 
product 

 that was suspended and/or 
resumed 

 that included a void, discount, 
supervisor authorisation, or 
gift card. 

 
 Advanced Search tab 

 You can only search in the 
Transaction List view, but can 
then change to another view 
to see the highlighted 
transaction in another format. 

 You can search by multiple 
common and/or specific 
criteria. 

 The bottom left of the screen 
indicates if the search data 
was ‘found’ or ‘not found’. 

 
 Common Options: 

Lists more popular searches. 

 Trans_Type: e.g. 31 is  a 
payment, 32 is item added 
(refer to the Filter tab for a 
full list of codes) 

 Till_No: e.g. 01 

 Operator_No: e.g. 9818 

 Trans_Name: used by Support 
to investigate processes; e.g. 
Logon, Payment, Txn End 

 Date: e.g. enter 03/12/2010 as 
20101203 

 Time: e.g. enter 13:54 as 1354 

 Transaction_ID: e.g. 000054 
 
 Transaction Specific search 

allows you to search on more 
specific scenarios. 
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